Google Translate

Stella inattivaStella inattivaStella inattivaStella inattivaStella inattiva
 
 
 
 
Installing quake III 1.31 is not so easy on Linux. This article describe all steps that I have done to install it on my pc. 
 
STEPS TO  INSTALL QUAKE III AREANA 1.31 ON LINUX UBUNTU 9.04
 
1) FOLDERS
Create 2 folders 
mkdir -p /usr/local/games/quake3/baseq3 (I think linux will create quake3 and quake3/linux folder)
 
2) FILE pak0.pk3 
Copy pak0.pk3 to /usr/local/games/quake3/baseq3
 
3) Q3 Point Release 1.31
Download the Q3 Point Release 1.31 from my site and save it in /usr/local/games/quake3
http://www.byman.it/downloads/q3linux/linuxq3apoint-1.31.x86.run
 
Note : maybe the browser will open as a page...from browser SAVE the file on you local disk...it works.
This is the Full program. It is not an update, so you dont need other software
 
4) INSTALLATION STEPS
a) Open a Terminal Console
b) switch as ROOT (su + enter)
c) copy the file linuxq3apoint-1.31.x86.run tin /usr/local/games/quake3 … if you have it in another folder
d) cd /usr/local/games/quake3
e) copy and paste the following command in the console : export _POSIX2_VERSION=199209
Note: Setup file use an old script command no more supported from bash...this command solve the a non compatible script problem
f) sh ./linuxq3apoint-1.31.x86.run
 
 
 
*******************************************************************
OTHER USEFUL STUFF
******************************************************************
 
How Install Quake3 on linux
- http://www.linux-gamers.net/modules/wiwimod/index.php?page=howto+quake3
- This is the file name of q3 point release 1.31 => linuxq3apoint-1.31.x86.run
 
 
Setup Error
Il file di setup "linuxq3apoint-1.31.x86.run" di linux require an old script and crashes during the setup process :  wrong checksum 
solution is easy, write this command before the setup process : export _POSIX2_VERSION=199209
 
 
OPEN GL Error
I found the solution on internet, run quake with the following parameter :
quake3 codered +set r_gldriver libGL.so.1.
http://ubuntuforums.org/archive/index.php/t-57462.html
 
  
How install RAR program
- apt-get install unrar
 
 
How enable Root in Ubuntu
- sudo passwd root
- http://lists.linux.it/pipermail/relug/2006-November/006168.html
 
 
No Sound
- seta snddevice "/dsp/snd1" ... it works for me... but starting from ubuntu 10 OSS support was removed from linux kernel 
In this blog you will find how get a linux kernel recompiled with OSS support : Vanvalkinburgh.org
 
 
Some notes from 
http://www.linuxquestions.org/questions/linux-games-33/no-sound-quake-3-linux-260975/page3.html
===========================================================================
open..
~/.q3a/baseq3/q3config.cfg or the autoexec.cfg
edit the line:
seta snddevice "/dev/dsp"
 
to:
 
seta snddevice "/dev/adsp"
ALSO TRY: "/dev/dsp1" or "/dev/dsp0" or even "/dev/dsp2" or adsp versions of all those. 
 
One of them should work. "/dev/dsp1" did the trick for me using ubuntu 6.06 x86_64 w/ 2 sound cards.
============================================================================
 
- have fun -